Documentation Center

  • Trials
  • Product Updates

Basic Editing

These topics describes how to use the 3D World Editor for common tasks involved in creating a virtual world.

For information about opening a file in the editor, see Open the 3D World Editor.

For a step-by-step tutorial, see Build and Connect a Virtual World.

Add Objects

Add virtual world objects by adding nodes in the tree structure pane. The hierarchy of nodes controls the scope to which node properties apply.

    Note:   Nodes must have unique names to work in the Simulink® 3D Animation™ product.

Approaches for Adding Objects

Use one of these approaches to add a node.

ApproachProcedure
Use the Nodes menu
  1. In the tree structure pane, select the parent node for the object that you want to add.

  2. Select Nodes > Add.

  3. Select appropriate submenus to add the node that you want.

Use a context menu for a node
  1. In the tree structure pane, right-click the parent node for the object that you want to add.

  2. Select the Add Node menu, and then select appropriate submenus to add the node that you want.

Insert an object from a library

For Material, Texture, and children nodes, select the Insert From menu option (from either the Nodes menu or from the context menu for a node).

For information about library objects, see 3D World Editor Library.

Add an inlined VRML fileFor a ROOT or children node, from the Nodes menu or the context menu for the node, select the Inline VRML File menu item.

The node that you add gets added to different locations in the hierarchy, depending on the node that you select to begin the process of adding a node.

Selected NodeLocation of Added Node
ROOTAt the bottom of the hierarchy
Node at the next level down from the ROOT node (for example, a Transform node).Above the selected node
A children nodeUnder the children node (as a child node of the selected node)

Copy and Paste a Node

You can copy a node below a top-level Transform node and paste that copied node to be a child of another node, including the ROOT node.

You can paste the copied node as either an explicit text copy (Paste) or as a referenced copy (Paste As Reference).

  • An explicit text copy allows you to edit properties of that node, independently from the original node that you copied.

  • A referenced copy node appears with the term USE. Referenced copies streamline the tree structure pane display. Edits that you make to the original (referenced) node are applied to the copied node, ensuring that the two nodes remain exact copies of each other.

To copy and paste a node:

  1. In the tree structure pane, select the node that you want to copy.

  2. Copy the node, using one of these techniques:

    • Select Edit > Copy.

    • Right-click the node and select Copy.

  3. Under the appropriate node, paste the copied node.

    • Paste the node using one of the following techniques:

      • Select the Edit > Paste or the Paste As Reference menu item.

      • Right-click the parent node and select Paste Node, and then select Paste or Paste As Reference.

Copy and Paste Between Virtual Worlds

In the same editing session, you can copy nodes from a virtual world in one VRML file to another virtual world in a different VRML file. After you copy the nodes from one virtual world, select File > Open to open the second VRML file where you want to paste the nodes.

Edit Object Properties

To define the characteristics of an object, in the tree structure pane, select the appropriate property. At the bottom of the 3D World Editor, use the object properties edit pane to change property values. Then click Apply.

The tree structure pane shows the current property values, which reflect your edits.

When you enter a numeric field value in the 3D World Editor, you can use MATLAB® expressions and MATLAB variables. For example, to convert an angle from degrees to radians, enter a MATLAB expression such as 25*pi/180.

Set Viewpoint Values in the 3D World Editor Based on Camera Position

You can use the current camera position to interactively specify a viewpoint in the 3D World Editor.

  1. Navigate to the position in the scene where you want the viewpoint.

  2. In the tree structure pane, right-click a Viewpoint node.

  3. Select Copy values from current camera.

Document a Virtual World Using Comments

To document a virtual world, in the object property edit pane, use the Comments tab for nodes and properties. Comments can help others understand the design of a virtual world.

Comments do not appear in the virtual world. They appear in the VRML file, next to the given node or property, on lines that begin with #.

Expand and Collapse Nodes

To expand a node in the tree structure pane, click the plus (+) sign to the left of the node. To collapse a node, click the minus (-) sign to the left of the node.

To expand or collapse all nodes in one step, select Tree > Expand All or Tree > Collapse All.

To expand subtrees within a node:

  1. In the tree structure pane, right-click a node.

  2. From the context menu, select Expand Subtree.

Alternative approaches for expanding the subtree for a node that you select in the tree structure pane are:

  • Select Tree > Expand Subtree.

  • Click the Expand Subtree toolbar button ( ).

Hide Default Values

To simplify the tree view, you can hide default VRML values. Select Tree > Hide Default Values. To display default values, clear the Hide Default Values option.

Wrap Nodes as Children of Another Node

To wrap contiguous nodes as children of another node:

  1. Select the nodes. You can use the Shift key to select contiguous nodes, and the CTRL key to select discontiguous nodes.

  2. Right-click the selected nodes and from the context menu, select Wrap By.

    As an alternative, on the 3D World Editor menu bar, select Nodes > Wrap By.

  3. From the list of nodes, select the node in which you want to wrap the selected nodes.

Remove Nodes

To delete one or more nodes, select the nodes and use one of these methods:

  • On the toolbar, click the red X button.

  • Click the Delete button.

  • Select Edit > Delete.

  • Right-click the node and select Delete.

From the Edit menu, you can also delete a specific child node or all the children nodes of a selected parent node, without deleting the parent node.

To cut a node and save it to the clipboard, select the node and use one of these techniques:

  • On the toolbar, click the scissors button.

  • Select Edit > Cut.

  • Right-click the node and select Cut.

Save and Export Virtual World Files

You can save your virtual world files as VRML (.wrl) files using the File > Save or File > Save As menu items.

If you use the Save option, the 3D World Editor renames the previous version of the file by appending .bak after the .wrl extension.

If you use the Save As option, the 3D World Editor saves the file using the new name that you specify. The file is saved in a form that is supported by the Simulink 3D Animation Viewer and 3D World Editor (for example, the saved file preserves links to the library texture files).

Use the File > Export menu item to export a fully VRML97–compliant file for use:

  • With other VRML tools

  • On different computers

  • In previous versions of the Simulink 3D Animation (previously the Virtual Reality Toolbox) product

For exported files, the 3D World Editor copies referenced inlined VRML files and texture files to the <filename>_files folder. It modifies the corresponding URLs for those files, so that they point to the <filename>_files folder.

Edit VRML Scripts

To add a VRML Script node:

  1. In the Tree structure pane, select the ROOT node.

  2. Select the appropriate kind of script, using the Node > Add > Common > Script menu.

To add Script interface elements:

  1. Right-click a Script node.

  2. Select the appropriate Add Interface Item menu option.

The following is an example of a Script node in the Tree structure pane.

To edit a url node, click the node and edit the URL code in the Object property edit pane.

Was this topic helpful?