Documentation Center

  • Trials
  • Product Updates

Partial Differential Equation Toolbox Release Notes

R2014a

New Features, Bug Fixes

Damping option for hyperbolic solver

You can include damping in the hyperbolic solver in matrix form. There is a new example of dynamics of a damped cantilever beam that shows how to use this feature.

R2013b

New Features, Bug Fixes

Display option in hyperbolic and parabolic solvers

You can disable the display of internal ODE solution details that the hyperbolic and parabolic solvers report. To disable the display, set the Stats name-value pair to 'off'.

Eigenvalue example

There is a new example of eigenvalues of a circular membrane. View the example here. To run the example at the MATLAB® command line:

echodemo eigsExample

R2013a

New Features, Bug Fixes

Performance and robustness enhancements in meshing algorithm

The meshing (geometry triangulation) functions in initmesh and adaptmesh provide an enhancement option for increased meshing speed and robustness. Choose the enhanced algorithm by setting the MesherVersion name-value pair to 'R2013a'. The default MesherVersion value of 'preR2013a' gives the same mesh as previous toolbox versions.

The enhancement is available in pdetool in the Mesh > Parameters > Mesher version menu.

New example

There is a new example of heat distribution in a radioactive rod. View the example here. To run the example at the MATLAB command line:

echodemo radioactiveRod

R2012b

New Features, Compatibility Considerations

Coefficients of parabolic and hyperbolic PDEs that can be functions of the solution and its gradient

You can now solve parabolic and hyperbolic equations whose coefficients depend on the solution u or on the gradient of u. Use the parabolic or hyperbolic commands, or solve the equations using pdetool. For details, see the function reference pages.

Graphics export from pdetool

You can save the current pdetool figure in a variety of image formats. Save the figure using the File > Export Image menu. See File Menu.

pdegplot labels edges and subdomains

pdegplot now optionally labels:

  • The edges in the geometry

  • The subdomains in the geometry

To obtain these labels, set the edgeLabels or subdomainLabels name-value pairs to 'on'. For details, see the pdegplot reference page.

New examples

There is a new example of uniform pressure load on a thin plate. View the example here. To run the example at the MATLAB command line:

echodemo clampedSquarePlateExample

There is a new example of nonlinear heat transfer in a thin plate. View the example here. To run the example at the MATLAB command line:

echodemo heatTransferThinPlateExample

There is a new example of a system of coupled PDEs. View the example here. To run the example at the MATLAB command line:

echodemo deflectionPiezoelectricActuator

pdesmech shear strain calculation change

The pdesmech function now calculates shear strain according to the engineering shear strain definition. This has always been the documented behavior. However, the previous calculation was performed according to the tensor shear strain calculation, which gives half the value of the engineering shear strain.

Compatibility Considerations

pdesmech now returns shear strain values exactly twice as large as before.

Compatibility Summary

ReleaseFeatures or Changes with Compatibility Considerations
R2014aNone
R2013bNone
R2013aNone
R2012bpdesmech shear strain calculation change
Was this topic helpful?