Documentation Center

  • Trials
  • Product Updates

Getting Started with the Image Acquisition Tool

This section describes an example of the basic work flow of using the Image Acquisition Tool to preview, acquire, and save image data. You don't need to do every step shown here, and you can change the order of some steps.

For information on the parts of the Desktop GUI or how to open the Tool, see The Image Acquisition Tool Desktop.

    Note:   With previous versions of the Image Acquisition Toolbox™, the files for all of the adaptors were included in your installation. Starting with version R2014a, each adaptor is available separately through the Support Package Installer. In order to use the Image Acquisition Tool, you must install the adaptor that your camera uses. See Image Acquisition Support Packages for Hardware Adaptors for information about installing the adaptors.

  1. Decide which device you want to work with.

    The Hardware Browser shows the image acquisition devices currently connected to your system. If the device you want to use is not connected to your system, plug it in and then select Tools > Refresh Image Acquisition Hardware to display the new device in the Hardware Browser.

  2. Choose the format to work with.

    The nodes listed under the device name are the formats the device supports. They may correspond to the different resolutions and color spaces that your device supports, or to different video standards or camera configurations. This information comes from your device adaptor. Select the format you want to use.

  3. Preview to check that the device is working and the image is what you expect.

    Click the Start Preview button.

    If necessary, physically adjust the device to achieve the desired image area, or use the Region of Interest tab to define the acquisition region.

  4. Decide how many frames you want to acquire.

    The number of frames that will be acquired when you start the acquisition is dependent on what is set in the Frames Per Trigger field on the General tab and the Number of Triggers field on the Triggering tab. For example, if you set Frames Per Trigger to 4 and Number of Triggers to 2, the total number of frames acquired will be 8.

    If you just want a snapshot of one frame, leave the default settings of 1 in both of those fields. If you want a specific number of frames, use the fields to set it.

    Alternatively, you can set the tool to acquire continuously and use the buttons in the Preview Window to manually start and stop the acquisition. This is discussed in a later step.

  5. Set any general or device-specific parameters you need to set, on those tabs of the Acquisition Parameters pane, or use the default settings.

  6. Choose your log mode, which determines where the acquisition data is stored.

    On the Logging tab, use the Log To field to choose to log to memory, disk, or both. Disk logging results in a saved VideoWriter file. If you choose memory logging, you can export your data after the acquisition using the Export Data button on the Preview Window.

    For more information on logging, see the Help for the Logging tab in the Desktop Help pane in the tool.

  7. Start the acquisition by clicking the Start Acquisition button.

    – If you set Trigger Type (on the Triggering tab) to Immediate, the tool will immediately start logging data.

    – If you set Trigger Type to Manual, click the Trigger button when you want to start logging data.

  8. Stop the acquisition.

    – If you set Frames Per Trigger (on the General tab) to 1 or any other number, your acquisition will stop when that number of frames is reached.

    – If you set Frames Per Trigger to Infinite, click the Stop Acquisition button to stop the acquisition.

    Note that you can also click Stop Acquisition to abort an acquisition if number of frames was specified.

  9. Optionally you can export data that was saved to memory.

    You can export the data that has been acquired in memory to a MAT-file, the MATLAB Workspace, VideoWriter, or to the Image Tool, Image File, or Movie Player tools that are provided by the Image Processing Toolbox™ software using the Export Data button. For more information, see the "Exporting Data" section of the Desktop Help on the Preview Window in the Desktop Help pane in the tool.

  10. Optionally you can save your configuration(s), using the File > Save Configuration or File > Export Hardware Configuration menus. For more information about these commands, see the "Image Acquisition Tool Menus" section of the Help on the Hardware Browser in the Desktop Help pane in the tool.

Was this topic helpful?